View Poll Results: What do you think I should do?

8. You may not vote on this poll
  • Give up, use the PAP and deal with it.

    4 50.00%
  • Try another VOIP gateway/Soft-PBX app: (recommendations?)

    1 12.50%
  • Keep at it and tell me when you've got the bugs worked out w/Asterisk.

    2 25.00%
  • I did it and here's how! (info?)

    1 12.50%
Results 1 to 10 of 21

Thread: Asterisk help

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Question Asterisk help

    Hello all!

    I'm a new asterisk user and for a while now I was using a couple of free VoIP providers for inbound and outbound testing. When I started working at another company, one of the perks was that I got a free VOIPo account.

    My very first reaction was joy at thinking how cool it'd be to finally deploy my own VoIP gateway for the house. I have a Dell 1U rackmount server that I scored from Goodwill for $30 because it wouldn't post. (they weren't using ECC RAM.)

    Well, I got the latest Trixbox/Asterisk/FreePBX ISO image and installed it and have run into a problem. Any VoIP device (softphone, Wifi-Phone, PAP2) can call out from the VOIPo trunk, but any attempt to call in gets a busy signal.

    I have checked Google and scoured the Asterisk/FreePBX/Trixbox forums hoping to find a solution but have come up with bupkiss. In fact, some of the settings for the inbound calling, caused me to lose outbound call as well but I was able to get that fixed.

    Here's where I need help. I need to find what I'm doing wrong and I hope I'm not the only person with VOIPo that has done this (much less pulled it off). I'm looking forward to getting this thing running and I have great plans for developing it from a testing box that I mess with on occasion to something that I can use full-time.

    I have tried entering my credentials into a Zyxel P2000W (WiFi VOIP phone), X-lite for PC, and the PAP2, all work flawlessly both incoming and outgoing, so I know it's not a network issue.

    Important information:
    Inbound calls fail, but outbound calls work great only when through Asterisk server.
    (Perfect quality, even on the old Zyxel Wifi phone.)
    {VOIPo assigned #}=Ten digit phone number, no leading "1"
    {VOIPo password}= VOIPO Assigned password.
    I have "Allow Anonymous Inbound SIP Calls" set to "Yes" but setting it to "No" causes the same symptom and does not change the logfile output.

    OS/Asterisk versions:
    Asterisk version: Asterisk 1.4.22-3 RPM
    CentOS release 5.3 (Final)

    Inbound Route settings:
    All default, except for the following items
    - DID Number = {VOIPo assigned #}
    - Destination - Ring Group 600 (all phones), (right now, only ext. 200 exists)

    Trunk Settings:
    (All fields not mentioned are using their default settings)
    - Outbound Caller ID = {VOIPo assigned #}
    - Maximum Channels =
    - Dial Rules NXXNXXXXXX
    - Trunk Name = VOIPo
    ===Outgoing Settings===
    PEER Details:
    username={VOIPo assigned #}
    secret={VOIPo assigned password}

    ===Incoming Settings===
    USER Context = {VOIPo assigned #}
    User Details:
    secret={VOIPo password}

    Registration String:
    {VOIPo assigned #}:{VOIPo password}

    When I get a call, this is the result of enabling SIP debug (level 10)

    Here is a sample of the sip debug info:

    [Jun 16 12:54:22] VERBOSE[2706] logger.c: Scheduling destruction of SIP dialog 'f4c8cf11-9d306831-59925@' in 32000 ms (Method: OPTIONS)
    [Jun 16 12:54:25] VERBOSE[2706] logger.c: Really destroying SIP dialog '396f1aae60b012da1be594557674bc4f@' Method: REGISTE R
    [Jun 16 12:54:47] VERBOSE[2706] logger.c:
    <--- SIP read from --->
    INVITE sip:s@ SIP/2.0
    Record-Route: <sip:;lr=on;ftag=gK0d74ea75;vsf=R1NE dnlmMjhPZklRTmJBTjNHU0R2eWYyOE9mSWo+ETUgHjcyNhcUFQ 8Bf159aX9acXYLfDA0FUQJQFwmCCgjNw-->
    Record-Route: <sip:;lr=on;ftag=gK0d74ea75>
    Via: SIP/2.0/UDP;branch=z9hG4bKe9e6.3aaa9112.0
    Via: SIP/2.0/UDP;rport=5060;branch=z9hG4bKe9e6.c271a bc4.0
    Via: SIP/2.0/UDP;rport=5060;branch=z9hG4bK0dB3f0 a756d33aed219
    f: "{Incoming Caller ID Name}" <sip:{Calling Phone #}@>;tag=gK0d74ea75
    t: <sip:{VOIPo Phone #}@>
    i: 386786062_71891924@
    CSeq: 32189 INVITE
    Max-Forwards: 68
    Accept: application/sdp, application/isup, application/dtmf, application/dtmf-relay, multipart/mixed
    m: <sip:{Calling Phone #}@;nat=yes>
    Supported: timer
    Session-Expires: 1800
    Min-SE: 90
    Content-Length: 356
    Content-Disposition: session; handling=required
    c: application/sdp

    o=Sonus_UAC 15405 4467 IN IP4
    s=SIP Media Capabilities
    c=IN IP4
    t=0 0
    m=audio 62624 RTP/AVP 0 18 4 101
    a=rtpmap:0 PCMU/8000
    a=rtpmap:18 G729/8000
    a=fmtp:18 annexb=no
    a=rtpmap:4 G723/8000
    a=fmtp:4 annexa=no;bitrate=6.3
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-15

    [Jun 16 12:54:47] VERBOSE[2706] logger.c: --- (20 headers 16 lines) ---
    [Jun 16 12:54:47] VERBOSE[2706] logger.c: Sending to : 5060 (no NAT)
    [Jun 16 12:54:47] VERBOSE[2706] logger.c: Using INVITE request as basis request - 386786062_71891924@
    [Jun 16 12:54:47] VERBOSE[2706] logger.c: Found peer 'VOIPo'
    [Jun 16 12:54:47] VERBOSE[2706] logger.c:
    <--- Reliably Transmitting (no NAT) to --->
    SIP/2.0 407 Proxy Authentication Required
    Via: SIP/2.0/UDP;branch=z9hG4bKe9e6.3aaa9112.0;recei ved=
    Via: SIP/2.0/UDP;rport=5060;branch=z9hG4bKe9e6.c271a bc4.0
    Via: SIP/2.0/UDP;rport=5060;branch=z9hG4bK0dB3f0 a756d33aed219
    From: "{Incoming Caller ID Name}" <sip:{Calling Phone #}@>;tag=gK0d74ea75
    To: <sip:{VOIPo Phone #}@>;tag=as5840874d
    Call-ID: 386786062_71891924@
    CSeq: 32189 INVITE
    User-Agent: Asterisk PBX
    Supported: replaces
    Proxy-Authenticate: Digest algorithm=MD5, realm="asterisk", nonce="137a0d35"
    Content-Length: 0

    [Jun 16 12:54:47] VERBOSE[2706] logger.c: Scheduling destruction of SIP dialog '386786062_71891924@' in 32000 ms (Method: INVITE)
    [Jun 16 12:54:47] VERBOSE[2706] logger.c:
    <--- SIP read from --->
    ACK sip:s@ SIP/2.0
    Via: SIP/2.0/UDP;branch=z9hG4bKe9e6.3aaa9112.0
    f: "{Incoming Caller ID Name}" <sip:{Calling Phone #}@>;tag=gK0d74ea75
    Call-ID: 386786062_71891924@
    To: <sip:{VOIPo Phone #}@>;tag=as5840874d
    CSeq: 32189 ACK
    Max-Forwards: 70
    User-Agent: Kamailio (1.4.3-notls (i386/linux))
    Content-Length: 0

    [Jun 16 12:54:47] VERBOSE[2706] logger.c: --- (9 headers 0 lines) ---
    [Jun 16 12:54:49] VERBOSE[2706] logger.c:
    <--- SIP read from --->

    I'll try anything, but while I do have the PAP2, I can't afford the digium card needed to bring a POTs line into the server. (theyre about $300!).

    Thank you for your help!
    Last edited by firestorm_v1; 06-16-2009 at 12:15 PM. Reason: added testing info w/ other devices.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts