Results 1 to 3 of 3

Thread: Registering a Cisco 7961 Phone

  1. #1
    Join Date
    Feb 2012

    Default Registering a Cisco 7961 Phone

    I know the rules say no device-specific troubleshooting, but I've gotten this to the packet-level capture and still don't know why it's failing. Had I known this 7961 would be so #*(%^ difficult to configure manually, I would have thrown it away and ordered a Grandstream or something. Anyway, too much time invested now to turn back.

    So far I've:
    - Converted SCCP phone to SIP image (8.5.2)
    - Figured out how to create the SEPXXXXX.cfg.xml file (and configured and username from the BYOD panel, and the password from the last email).
    - tried many configuration options, including enabling NAT support, but I still can't get registered.

    Today I captured packets from the phone starting up. The registration message *seems* to me to be formatted correctly, but I'm getting a "401 Unauthorized" message back from VOIPo.

    Here's the register packet from my phone. This is captured inside the network so you see the private IP instead of the public IP on the network layer of the packet.

    No.     Time        Source                Destination           Protocol Length Info
        382 55.840001             SIP      756    Request: REGISTER | 
    Frame 382: 756 bytes on wire (6048 bits), 756 bytes captured (6048 bits)
    Raw packet data
    Internet Protocol Version 4, Src: (, Dst: (
    User Datagram Protocol, Src Port: 49380 (49380), Dst Port: sip (5060)
    Session Initiation Protocol (REGISTER)
        Request-Line: REGISTER SIP/2.0
            Method: REGISTER
                Request-URI Host Part:
            [Resent Packet: False]
        Message Header
            Via: SIP/2.0/UDP < MY PUB IP >:5060;branch=z9hG4bKeaa5bd04
                Transport: UDP
                Sent-by Address: < MY PUB IP >
                Sent-by port: 5060
                Branch: z9hG4bKeaa5bd04
            From: <sip:<MY TEL NO>>;tag=002155039275000208182de8-0246ff04
                SIP from address: sip:<MY TEL NO>
                    SIP from address User Part: <MY TEL NO>
                    SIP from address Host Part:
                SIP from tag: 002155039275000208182de8-0246ff04
            To: <sip:<MY TEL NO>>
                SIP to address: sip:<MY TEL NO>
                    SIP to address User Part: <MY TEL NO>
                    SIP to address Host Part:
            Call-ID: 00215503-92750002-7564b7e8-d31dd104@< MY PUB IP >
            Max-Forwards: 70
            Date: Fri, 20 Mar 2015 19:07:26 GMT
            CSeq: 101 REGISTER
                Sequence Number: 101
                Method: REGISTER
            User-Agent: Cisco-CP7961G-GE/8.5.2
            Contact: <sip:<MY TEL NO>@< MY PUB IP >:5060;transport=udp>;+sip.instance="<urn:uuid:00000000-0000-0000-0000-002155039275>";+u.sip!"308"
                Contact URI: sip:<MY TEL NO>@< MY PUB IP >:5060;transport=udp
                    Contact URI User Part: <MY TEL NO>
                    Contact URI Host Part: < MY PUB IP >
                    Contact URI Host Port: 5060
                    Contact URI parameter: transport=udp
                Contact parameter: +sip.instance="<urn:uuid:00000000-0000-0000-0000-002155039275>"
                Contact parameter: +u.sip!"308"\r\n
            Supported: (null),X-cisco-xsi-7.0.1
            Content-Length: 0
            Reason: SIP;cause=200;text="cisco-alarm:25 Name=SEP002155039275 Load=SIP41.8-5-2S Last=initialized"
                Reason Protocols: SIP
            Expires: 3600
    The first reply is a "Status: 100 Trying" immediately followed by a "Status: 401 Unauthorized" message. I'm hoping someone can tell me what the VOIPo server doesn't like about this invite and I'll figure out how to beat this phone into submission.

  2. #2
    Join Date
    Feb 2012

    Default Re: Registering a Cisco 7961 Phone

    A little progress. I found the SIP registration process actually expects a "401 Unauthorized" with the first registration attempt. That initial 'unauthorized' should contain a challenge. The SIP client then uses the challenge to create a response. It seems the VOIPo server is doing its job and creating the challenge, but my phone is ignoring the challenge and resending the original registration packet. I verified the packet is the same every time my phone sends it except the sequence number.

    I suspect a bug so I'll load a later version (9.3.1SR4) later and re-test. If I ever get this working, I'll post the configs!

  3. #3
    Join Date
    Feb 2012

    Default Re: Registering a Cisco 7961 Phone

    I upgraded to 9.3(1)SR4 and couldn't get it to even attempt to register. I've downgraded back to 8.5(2) and am back at square 1. Please reply with any ideas.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts